Answered
Controllers Vanish

There's an odd bug where sometimes, instead of going into the projector screen at the beginning, the screen is black, with no audio. I can click the trigger to bypass the spash screen, but when I go to the next scene, I do not have controllers. My avatar's hands follow the controllers position, but the world does not respond to them (no colliders).

This happens occassionally, and every time I hit "prepare for build". I can find no rhyme or reason of its occurance.

The hack solution I've found is to start the program with other scenes open, until the controllers appear again. Sometimes this works, and sometimes it doesn't.

Here's my error log:

EDIT

A restart of the computer, recalibration of oculus fixed the problem (it wasn't self correcting.) Here's the error log after the restart.

  
Posted 1 years ago
Edited 1 years ago
  
Had a call with Annie, some more details on this bug. It appears Time.detlaTime is not functioning correctly, and is returning 0. Not sure how this is effecting the controllers, but it is impacting the splash scene Brennan Hatton   1 years ago Report
Votes Newest

Answers


Upon further investigation with Annie it seems that something is changing the value of Time.timeScale to 0. A temporary fix for now until we can identify the source of this is to detect if this has happened and revert it.

Create a new C# script scalled TimeScaleBugFix.cs

Put this code in an update loop

//Check if something has changed the timescale
if(Time.timeScale != 1)
{
	//put the timescale back to what it should be
	Time.timeScale = 1;		
}

Attach this to EqualRealityTools

EDIT

EqualReality0.017.003_Patch04_20180802.unitypackage will now fix this with the script TimeScaleFix. Add it to EqualRealityTools Object.

From version EqualReality00.019.000 onwwards, this script will be included until the cause of the error is found and eliminated.

  
Posted 1 years ago
Edited 1 years ago